Disruption of service for Cards and International Payments
Resolved·Degraded performance

All services are now performing as expected

Tue, Mar 11, 2025, 04:00 PM
(1 month ago)
·
Affected components
🔁 API - Cards
🔁 API - Payments
💳 Card Payments
Updates

Resolved

All services are now performing as expected

Tue, Mar 11, 2025, 04:00 PM

Monitoring

We have restored service and are monitoring for further errors

Tue, Mar 11, 2025, 03:36 PM(23 minutes earlier)

Investigating

We are aware of a disruption of service impacting Cards and International Payments and are currently investigating the issue.

Tue, Mar 11, 2025, 03:27 PM